Please update the following plugins (for next release)

General questions about using ExamDiff Pro, ideas for new features, bug reports, and usage tips.
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

Thanks, will update.
psguru
PrestoSoft
Alpengreis
Expert Member
Posts: 95
Joined: Sat Oct 04, 2014 8:16 am
Location: Schweiz

Re: Please update the following plugins (for next release)

Post by Alpengreis »

About the jq yet (if it's interesting) for you:

See the URL ...

https://github.com/jqlang/jq/releases/tag/jq-1.7

to direct download of the jq-win32.exe binary.

An advantage could be that the new version is MUCH smaller now.
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

Yes, saw it, thanks.
psguru
PrestoSoft
Alpengreis
Expert Member
Posts: 95
Joined: Sat Oct 04, 2014 8:16 am
Location: Schweiz

Re: Please update the following plugins (for next release)

Post by Alpengreis »

Hello

There is a new update for cURL, it's v8.4.0, which is security related too.

Greetings
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

Thanks, we'll update it in the next build.
psguru
PrestoSoft
Alpengreis
Expert Member
Posts: 95
Joined: Sat Oct 04, 2014 8:16 am
Location: Schweiz

Re: Please update the following plugins (for next release)

Post by Alpengreis »

JFI

I found finally a newer odt2txt plugin. It's the version 0.5.3 from October, 29th, 2022.

Personally, I "installed" the 64-bit version. But there exist also a 32-bit version on the following website:

https://repo.msys2.org/mingw/i686/

Search for odt2txt or for file mingw-w64-i686-odt2txt-0.5-3-any.pkg.tar.zst ... you will find a compiled .EXE in the archive.

Greetings
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

Thanks for posting this, will check it out.
psguru
PrestoSoft
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

BTW, what's the location of the 64-bit version that you got?
psguru
PrestoSoft
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

Hmm, I tried the 32-bit version of odt2txt from https://repo.msys2.org/mingw/i686/, and it didn't work: no output and an error for files that the old plug-in, version 0.3, handles just fine. The size of the new version is also suspiciously small.
psguru
PrestoSoft
MSpagni
Expert Member
Posts: 544
Joined: Mon Mar 30, 2009 12:53 am
Location: Italy

Re: Please update the following plugins (for next release)

Post by MSpagni »

I didn't find any 32 bit version of odt2txt there.
I only found "mingw-w64-i686-odt2txt-0.5-3-any.pkg.tar.zst".

Running the contained odt2txt in WinXP 32 bit results in "odt2txt.exe - Impossible to find libiconv-2.dll".
Maybe this can explain the reduced size.

Off topic: since the specifications are public and free, I'm surprised 7zip don't handle the files .zst.
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

I was referring to odt2txt.exe file in the bin folder of mingw-w64-i686-odt2txt-0.5-3-any.pkg:

Code: Select all

│   .BUILDINFO
│   .MTREE
│   .PKGINFO
│
└───mingw32
    ├───bin
    │       odt2txt.exe
    │
    └───share
        └───man
            └───man1
                    odt2txt.1.gz
I didn't get the message you got, just an error and no output.
psguru
PrestoSoft
MSpagni
Expert Member
Posts: 544
Joined: Mon Mar 30, 2009 12:53 am
Location: Italy

Re: Please update the following plugins (for next release)

Post by MSpagni »

That's exactly the exe file I used.

I made some mental confusion because of the name of the package (W64) and the directory name (mingw32), but I tried on WinXP 32 anyway.

I repeated the test now and I got the same result: "Impossible to find libiconv-2.dll".
User avatar
psguru
Site Admin
Posts: 2246
Joined: Sat May 15, 2004 4:23 pm
Location: California
Contact:

Re: Please update the following plugins (for next release)

Post by psguru »

It's probably because the exe was not statically built.
psguru
PrestoSoft
MSpagni
Expert Member
Posts: 544
Joined: Mon Mar 30, 2009 12:53 am
Location: Italy

Re: Please update the following plugins (for next release)

Post by MSpagni »

Yes, indeed.
Alpengreis
Expert Member
Posts: 95
Joined: Sat Oct 04, 2014 8:16 am
Location: Schweiz

Re: Please update the following plugins (for next release)

Post by Alpengreis »

Sorry for late reply ...

About the odt2txt:

It's from https://repo.msys2.org/mingw/x86_64/

I forgot: indeed I had to add the following files:

libiconv-2.dll
libpcre-1.dll
libpcreposix-0.dll
zlib1.dll

I took those files from my Git (also 64-bit) installation.

This is probably a bit (too) much effort then to make it available?

Sorry for the confiusion!


A new cURL version is available: 8.5.0 which is security relevant.

A new jq version is available (1.7.1 on https://github.com/jqlang/jq/releases) which is also security relevant.


Greetings
Post Reply